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AAbboouutt  tthhiiss  DDooccuummeenntt  
 

 

ZiPCAD  is a full-featured CAD program.  Because it is generally a secondary CAD 
system for end-users, every effort has been made to make ZiPCAD  as simple and intuitive 
to use as possible, resulting in a rather short manual despite its robust feature set. 

The features described below are those of ZiPCAD|Pro – the most feature-laden version 
of ZiPCAD.  A subset of these features is also applicable to other ZiPCAD  products, such 
as ZiPCAD|View. 

Documentation Revisions 

This manual is available at zipcad.com/manual.pdf and is frequently updated.  If you 
would like to be added to ZiPCAD’s mailing list and receive notices of manual updates 
and other ZiPCAD news, please send an empty e-mail message to addme  @  zipcad.com. 
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11..  SSyysstteemm  RReeqquuiirreemmeennttss  
 

 

This chapter describes the system requirements of the device and its companion desktop 
computer. 

Compatible Palm OS Devices 
ZiPCAD will run on any Palm OS device running OS version 3.1 or higher, which 
includes 95% of Palm OS devices in distribution today.  Device brands include Palm, 
Sony, iQue, Zodiac, and Fossil. 

ZiPCAD will properly display on the standard screen sizes of 160x160, 320x320, and the 
larger format 320x480 device screens.  ZiPCAD will run on both color and 
monochromatic devices. 

You must have a minimum of 700K RAM available at the time of installation to install 
the program and support files. Drawings can be saved in RAM and on the expansion card 
and are typically average 10K to 100K in size. 

ZiPCAD will not run on Pocket PC, WindowsCE, or Symbian devices. 

Windows, Mac, and Linux 
ZiPCAD is available bundled with a Windows-compatible conduit or without a conduit 
for Mac/Linux users or devices that do not Hotsync to any computer. 

Windows 

The Windows version is bundled with a conduit program that resides on the PC for 
exporting comma separated values (CSV) punchlist files and importing and exporting 
DXF files directly to and from the PC when performing a HotSync operation. 

Mac/Linux and GoodLink™ 

ZiPCAD is available in a conduit-less version for users that hotsync to a Mac or Linux 
computer and users of devices that do not Hotsync to any computer, such as those 
networked with GoodLink.  These configurations can import and export files directly to 
the expansion card.  The ported files on the expansion card can then be uploaded and 
downloaded to and from the desktop computer using an inexpensive card reader, the Palm 
Desktop program bundled with the Palm OS device, or third-party programs.  For more 
information on importing/exporting see “Chapter 5. Importing and Exporting.” 
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22..  IInnssttaallllaattiioonn  aanndd  
RReeggiissttrraattiioonn  

 

 

This chapter describes how to install trial versions and registered (purchased) versions of 
ZiPCAD products.  

Windows Installations 
1. Download the latest installation executable (.exe file) for Windows from 

zipcad.com/products.html. The downloaded file is named ZiPCADPro.exe.  Save it to 
the desktop or other convenient location. 

2. Run the executable ZiPCADPro.exe by double clicking it and follow the instructions.  

3. Hotsync your Palm OS device.  

4. ZiPCAD  has a 30-day trial period, after which some features, such as saving, are 
disabled.  To unlock the program you must register by purchasing a license.   

Macintosh and GoodLink Installations 
1. Download the latest installation zip file from zipcad.com/products.html. The 

downloaded file is named ZiPCADPRO.zip.  Save it to the desktop or other convenient 
location.  

2. Unzip the file to create the folder "ZiPCADPRO."  

3. Install all of the .prc and .pdb files to your device using Palm Quick Install or third-
party software such as GoodLink.  

1. ZiPCAD  has a 30-day trial period, after which some features, such as saving, are 
disabled.  To unlock the program you must register by purchasing a license. 

Registration 
Users can install and use ZiPCAD  for free for a limited trial period; after which, features 
such as opening and saving are disabled.  To enable these features, you must register the 
software. 

Beamed copies can be used for the free trial but cannot be registered.  If you have a 
beamed copy, you must download and install a full version. 
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1. You must purchase ZiPCAD  to receive a registration key.  After registering, a unique 
key will be e-mailed to you.  (If you have already downloaded and installed a demo 
version, you do not need to reinstall the software.)  

2. Start ZiPCAD  on your Palm OS device.  Tap the menu button and  go to “Settings 
>About ZiPCAD > Register…”  

3. Enter your unique registration key.  

Upgrading 
New versions of ZiPCAD are periodically available for download at www.zipcad.comwww.zipcad.com or 
from resellers.  These versions should generally be installed over existing versions of 
ZiPCAD to preserve currently settings.  You generally do not need to uninstall your 
current version before installing a new version.  (Uninstalling your current version will 
lose some settings; such are your registration key and general preferences.) 

Major Upgrades 

Registered users can purchase major releases of ZiPCAD  at a reduced price.  Major 
releases are denoted by an ending zero (e.g., 2.0, 3.0).   

Minor Upgrades 

Minor upgrades are indicated with a non-zero decimal number (e.g., 2.3, 3.1) and are free 
to registered users of the previous major upgrade.  To install an upgrade to a registered 
version simply install the upgrade over the existing program. 

www.zipcad.com
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33..  GGeettttiinngg  SSttaarrtteedd  
 

ZiPCAD  is a full-featured 2-D CAD program.  Because ZiPCAD  uses many of the 
standard CAD conventions found in most CAD programs, such as trimming, grouping, 
layers, etc., the learning curve for CAD users is quite small.  However, ZiPCAD  was not 
modeled after any specific CAD program, such as AutoCAD, ArchiCAD, or 
VectorWorks, so it will have a slight learning curve regardless of previous CAD 
experience.  Non-CAD user’s can certainly learn ZiPCAD quickly, but their learning 
curve will be slightly longer because they are learning standard CAD conventions as well 
as ZiPCAD’s interface. 

ZiPCAD  strictly adheres to the interface conventions of Palm OS devices.  So, the 
techniques used for accessing menus, inputting data, quitting the application, etc, will be 
familiar for Palm OS users.  If you are new to both ZiPCAD  and Palm devices, please 
familiarize yourself with the conventions of the device before attempting to learn 
ZiPCAD . 

Videos 
The fastest way to get up to speed with ZiPCAD is to watch the free tutorial videos before 
reading this manual.   The videos are available for download at the ZiPCAD website: 
www.zipcad.comwww.zipcad.com .  If you have a ZiPCAD  CD, the videos are located in the “Videos” 
folder. Tools that are demonstrated in a ZiPCAD video are accompanied by a video icon 

in this manual:  

Common Uses 
Because ZiPCAD  is a full-featured CAD program, it has countless uses.  The more 
common applications are outlined below. 

Drawing 

ZiPCAD|Pro has a full suite of drawing tools for quickly drawing precise 2-D CAD 
drawings or freehand sketching.  After activating a drawing tool (see “Draw Tools” on 
page 19) simply tap locations in the drawing area to create entities. With the exception of 
the Sketch tool, do not drag the stylus when drawing.  (Dragging the stylus performs an 
Anytime Window that performs a zoom operation, which is handy for quickly zooming in 
on details of your drawing – see “Anytime Windowing” or page 15.)  For example, to 
draw a line, simply activate the Line tool, tap the start point of the line, lift the stylus, and 
then tap the end point.   

ZiPCAD  was designed to allow users to simultaneously specify entities freehand or enter 
exact dimensions.  As you draw with ZiPCAD , the coordinates of tap locations are 
displayed at the bottom of the screen and can be modified at any time by simply tapping 

www.zipcad.com
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their value and entering an exact dimension.  For more detail, see “Coordinates and 
Offsets” on page 16. 

While drawing with ZiPCAD, the command prompt will guide you with the steps required 
for using the active tool.  If you have a question while using ZiPCAD , glancing at the 
command prompt should clarify things. 

Floor Plans 

ZiPCAD|Pro is often used by design professionals to quickly and accurately document 
floor plans of existing buildings or other site information.  A unique Walls&Gaps tool 
(patent pending) allows users to quickly draw walls, windows, and doors by tapping in the 
drawing and specifying exact measurements (see page 19).  Dimensions can be entered 
manually or optionally uploaded from a laser distance meters via Bluetooth (see “Chapter 
6. Linking to a Distance Meter,” page 39). 

DXF Drawings  

Technical drawings in the DXF file format can be imported into ZiPCAD for viewing and 
modifying.  The drawings can be imported from a PC during a Hotsync operation or 
directly from the device’s expansion card.  Drawings can also be created in ZiPCAD and 
exported to a desktop computer where they can be loaded with other CAD and DXF-
compatible programs.  Likewise, desktop CAD programs can export DXF drawings, 
where they can be loaded into ZiPCAD via the expansion card or a PC Hotsync operation.  
For more information on DXF porting, see “Chapter 5. Importing and Exporting,” page 
35. 

Punchlists  

Punchlists are lists of outstanding project ‘to do’ items which be created quickly with 
ZiPCAD’s preset punchlist menus (see “Draw Tools,” page 19).  Punchlists are exported 
as a spreadsheet in comma separated format (CSV), which is compatible with most 
spreadsheet programs, including Microsoft Excel and WordPerfect.  The location of 
punchlist items are specified the drawing, which can be exported in a DXF drawing and 
cross-referenced with the punchlist spreadsheet, creating powerful punchlist reports.  
Multiple punchlists can be merged into a single punchlist with the “File > Import…” 
menu option, allowing several people to modify punchlist individually and then merge 
then merge them into a single punchlist (see “Importing punchlist CSV files,” page 37). 

 

Interface 

  ZiPCAD’s interface is depicted in Figure 1.  All tools are activated from the 
Toolbar in the lower-left portion of the screen.  After starting a tool, the user is instructed 
on what to do by the Command Prompt.  If the “i” button is present, tapping it will give 
more explicit information or tips. 
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As you use ZiPCAD, input fields are often displayed at the bottom of the screen.  These 
fields show current values and settings for the active tool.  Tapping on these values 
invokes popup keypads and other input dialogs. The Graffiti Area at the bottom of the 
screen is for entering values and shortcuts (see section Shortcuts p.13). Devices with 
physical keypads can enter values directly through the keypad. 

 

Figure 1 - The ZiPCAD interface 

Toolbar 

Tools are accessible from the toolbar on the lower left corner of the screen.  Pressing a 
toolbar button activates a popup menu.  Each tool in the popup has an icon associated 
with it, a tool name, and a shortcut letter (see Figure 2). 

Command Prompt 

The Command Prompt guides the user through the steps necessary for using the active 
tool (see Figure 1).  For example, after starting the Line tool, the user is prompted with the 
instruction “Tap start pt.”  After tapping a start point, the user is prompted with “Edit pt’s 
(x,y) or tap pt” indicating that the user can edit the coordinates of the start point’s 
coordinates in the bottom-right portion of the screen, or simply tap the next point on the 
line.  
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Figure 2 - Toolbar popup 

Input Fields 

As the user draws, relative information, such as the coordinates of the current point, is 
listed in the bottom-right portion of the screen.  Tapping an input field will cause a 
ZiPCAD keypad to pop-up (see Figure 3) which allows the user to modify the values in 
the input fields.  Keypads allow users to quickly enter precise dimensions and angles.   
When in Imperial Mode (see page 33 , “General Preferences”), fractional inches can be 
entered by pressing the fraction keys one or more times resulting in a value equal to the 
cumulative sum of the keys pressed –  e.g., 3/4" is entered by tapping the “1/4” key three 
times.   

Users can specify the coordinate system as Cartesian (x, y) or Polar (distance, angle), the 
units metric or imperial, and other settings by tapping the menu button and going to 
“Settings > General Preferences” (see Figure 4).  These settings apply to the current 
drawing and subsequent drawings. 

 

 

Figure 3 - Popup distance keypad 
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The “i” Button    

Some tools have powerful features that may not be immediately obvious to users.  Such 
tools display an “i” button (see Figure 1) that gives information pertinent to the current 
tool.  E.g., the informational tip for the Door tool tells the user that he or she can modify 
the newly created door by changing the settings under “Settings > Windows and Doors.”  
It is recommended that new users tap on the “i” button whenever it appears to ensure that 
they are taking advantage of the full range of ZiPCAD’s many powerful features.   

 

Figure 4 - General Preferences 

Menus 

‘Hidden’ pull-down menus provide several powerful commands and setting options.  
They are accessible by tapping the Menu Button (see Figure 5).  These menus contain 
commands common to most desktop office and CAD programs and are described in detail 
in the “Chapter 4. Features” on page 19. 

Shortcuts 

To increase drawing speed, shortcuts are provided for most ZiPCAD  tools.  There are four 
types of shortcuts: Command Bar, Slash, Single-letter, and Toolbar Double Taps. 

Command Bar Shortcuts 

Commands located in the Edit menu are frequently used and are accessible by performing 
an upward ‘slash’ in the Graffiti Area (see Figure 6).  After performing an upward slash, 
the command bar is shown at the bottom of the screen with icons representing the active 
tools of the Edit menu.  (Note that the slash must be done with an upward motion from 
the lower left to the upper right.)  Only the Edit tools that are currently applicable are 
listed.  For example, the delete icon will only be shown when entities are selected in the 
drawing.  (See page 32, “Edit Menu,” for more information.) 

To determine the function of each icon in the command bar, simply place and hold the 
stylus on the symbol.  Text will appear that describes the function.  For example, after 
drawing a line, invoking the command bar and tapping and holding the undo arrow will 
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display the text “Line Undo” to the left of the arrow.  Drag the stylus off the icon before 
releasing to cancel the operation. 

Menu Shortcuts 

Tools found in the hidden pull-down menus are accessible by performing a slash followed 
by writing the tool’s shortcut letter in the Graffiti Area.  The shortcuts for the menu tools 
are listed next to their name (see Figure 5).  For example, to create a new drawing, write 
“/N” in the Graffiti Area. 

 

Figure 5 - Menus accessible by tapping the Menu Button 

Devices that have a physical keyboard, instead of a Graffiti Area, access menu shortcuts 
by pressing the menu button (instead of slashing) followed by the letter associated with 
the menu options.  For example, for accessing the General Preferences, press the menu 
button followed by the letter ‘f’. 

Single-Letter Shortcuts 

Tools accessible from the main toolbar can be activated by simply writing the tool’s 
shortcut letter in the Graffiti Area without a proceeding slash.  (Users of devices with 
physical keyboards need only to press the appropriate key.)  The shortcut letters are listed 
adjacent to their corresponding tool name in the popup (see Figure 2).  E.g., to activate the 
Line tool, simply write “L” in the Graffiti Area (or press the ‘L’ button on physical 
keyboards).  Single-letter shortcuts can be customized by going to “Settings > Custom 
Shortcuts.” 
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Figure 6 - Command bar shortcuts accessible by ‘slashing’ in the Graffiti Area 

Toolbar Double-Tap 

Tapping one of the four toolbar buttons shows its corresponding popup.  Tapping the 
same main toolbar button again will activate the previously active tool from that group.  
For example, if the Line tool is active (accessible from the right-most of the four toolbar 
buttons) and the user subsequently activates a Corner tool (accessible from the left-most 
button), double-tapping the right-most toolbar button will reactivate the Line tool. 

The Drawing Area 

The largest portion of the device’s screen is dedicated to the drawing area.  With the 
exception of the Sketch tool, all interaction with the drawing and its entities is done with 
single taps – do not drag the stylus on the screen when creating objects.  For example, 
when creating a line, tap the starting point of the line, lift the stylus, and tap the ending 
point of the line.  There are only two operations or tools that require the stylus to be 
dragged: the Sketch tool and when Anytime Windowing. 

Anytime Windowing and Device-key Viewing 

In addition to the View tools available from the main toolbar, two View tools for 
navigating the drawing are always active:  Anytime Windowing and Device-key Viewing. 

Anytime Windowing  allows the user to zoom and window to a portion of the drawing at 
anytime by dragging the stylus across the screen.  The most recent ten windows specified 
are stored and can be reviewed by the Prev Window and Next Window view tools.  Note 
that you can perform this operation at anytime, regardless of the active tool. 
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You can pan-and-zoom in the drawing at anytime using the device keys at the bottom of 
the device (Calendar, Addresses, etc.).  See Figure 1 for the mapping of a typical device 
with a navigator.  Some devices have fewer buttons and, consequently, a slightly different 
mapping.  For the mapping on your particular device, tap the menu button and go to 
“Settings > Help.”  The key mapping for your particular device will be listed there. 

Coordinates and Offsets 

As you draw, ZiPCAD  shows the coordinates of the current tap point in the input fields at 
the bottom of the screen.  When in World coordinates mode (see page 33, “General 
Preferences”) the reference point is the fixed origin of the drawing.  When in Relative 
coordinates mode, the reference point is continually reset by ZiPCAD to a recently tapped 
point, generally to the previously tapped point.  

You can exploit the Relative mode to offset drawn objects a specified amount.  Figure 7 
shows a 1’-0” radius circle with its center offset 4’-0” at a zero-degree angle from a 
corner intersection.  To perform this operation, follow the steps below.  (Before following 
this example go to “Settings > General Preferences” and change your current settings to 
“Imperial,” “Feet,” “3’-6”,” “Polar,” “Relative,” and “Degrees.”  Tap “Done” to return to 
drawing.)  

1. Select the Circle tool. 

2. Tap the intersection point of two lines.  The input fields at the bottom of the screen 
appear with d=0 which indicates that the current point is at the reference point just 
tapped.  (For convenience the angle field, “a” is set to match the angle of the line 
tapped, if any, when specifying the snap point.  This can greatly simplify offsetting 
when working with angled lines and walls.) 

3. Edit the input fields to the desired relative location.  Tap the “d” (distance) input field 
and in the pop-up keypad tap [4] [ft] [Enter]; then tap the “a” (angle) input field and in 
the pop-up keypad tap [0] [Enter]. 

4. Tap an approximate location of a point on the circle.  The circle is then drawn and the 
input fields update to show the location of the point relative to the center of the circle. 

5. Edit the input fields to the desired radius by tapping the “d” input field and in the 
popup keypad and tapping [1] [Enter].  (Note that it is not necessary to tap [ft] because 
Feet was set as the default keypad unit prior to Step 1.) 



 

ZiPCAD v3.1 User Manual     |    17 

 

Figure 7 - A circle of radius 1’-0” is drawn centered 4’-0” from the intersection of two 
lines 

Modifying Line Type and Color 

As entities are created, their line color, type, and layer, are determined by the settings in 
the Line Type/Color menu and the Layers menu.  The active line color and type are 
displayed in ZiPCAD’s interface (see Figure 1). 

To modify the color and line type of one or more objects, select all of the objects to 
modify, tap the menu button and “Settings > Line Type/Color,” select the desire 
attributes, and click “Done.”  The attributes of the selected entities and subsequent new 
entities will be set to the new attributes. 

Modifying Layers 

Layers can be added, renamed, and deleted in the “Settings > Layers” dialog.  Entities in 
the drawing can be moved from one layer to another by cutting the entities to the 
clipboard and pasting them to the desired layer.  To do this, select the desired entities, 
select “Edit > Cut,” change the active layer in the “Settings > Layers” menu, and paste the 
entities into the drawings by selecting “Edit > Paste.” 

The “Match” Button 

The current settings for line type, color, and active layer, can be modified to ‘match’ an 
entity in the drawing.  To do this, activate the Pick tool (see “Select Tools,” pg. 28) and 
tap on the entity in the drawing with the desired line type, color, and layer.  The “Match” 
and “Edit” buttons appear at the bottom of the screen.  Tapping the “Match” button 
changes the current line attributes and active layer to match the selected entity.  The new 
active layer is temporarily flashed in the Command Prompt and the active line type and 
color is updated and displayed in the interface (see Figure 1). 

The “Edit” Button 

To modify the geometry of an object, such as the length of a line or the radius of a circle, 
activate the Pick tool and tap on the entity to modify.  The “Match” and “Edit” buttons 
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appear at the bottom of the screen.  Tap the “Edit” button to display an editor for 
modifying the entity’s attributes. 

If more than one entity is selected, tapping the “Edit” button presents the user with an 
editor for modifying the color, line type, and/or active layer of the selected entities.  
Selecting one or more of these options and tap “Done” to change the corresponding 
values of the selected entities to match the active settings. 

When only one entity is selected, tapping “Edit” displays a geometry editor, as described 
above.  At the bottom of each editor is a “More…” button.  Tap it to close the geometry 
editor and open the color, line type, and layer editor. 

A common operation is to change the layer and line attributes of several entities in the 
drawing to match those of an existing entity in the drawing.  To do this, simply activate 
the Pick tool, tap the entity with the desired attributes and tap the “Match” button.  Then 
select the entities to modify, tap “Edit,” select the attributes to modify, and tap “Done.” 
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44..  FFeeaattuurreess  
 

ZiPCAD’s interface is optimized to provide a full set of features while dedicating the 
largest amount of the device’s screen to the drawing area.  All of ZiPCAD’s features are 
accessible from its main toolbar or its hidden pull-down menus. 

Toolbar Tools  
The main toolbar on the lower left portion of the screen has four buttons (see Figure 1).  
Some tools are modal and their icon will be displayed in the toolbar while the tool is 
active.  Other tools, such as the Extents tool, simply perform their operation and then 
return control back to the previously active tool. 

Draw Tools  

The right-most button of the toolbar contains the Draw tools.  These tools allow the user 
to create lines, shapes, text, etc., in the drawing. 

 

Line: After activation, this tool displays a checkbox at the bottom of the screen titled 
“Continuous.”  The behavior of the tool depends on this setting. 

Continuous (checked):  Draws continuous line segments end-to-end. If a series of 
taps falls on the same line, alternating lines and gaps will be drawn (patent 
pending).  Gaps are helpful for rectilinear drawings with openings, such as floor 
plans, allowing the user to draw walls and openings without switching tools.  Note 
that turning on “Settings > Snap Preferences > Snap Angle”  increases efficiency of 
drawing shapes with regular angles. 

Continuous (unchecked):  Draws a line as defined by two points.  After each line is 
created, a new line is started.  

 
 
 

  Walls & Gaps (patent pending): Draws walls, windows and doors without 
requiring a tool change.   Each time the tool is activated, the input fields at the 
bottom of the screen specify the current wall width and one of three types of wall 
specification lines ("Inside,” “Outside,” or “Center").  When drawing, if the 
direction of the wall changes (e.g., the corner of a room) wall segments are 
continuously drawn.  However, if you specify the next point in the same line 
direction as the preceding wall segment, a 'gap' is drawn.  The gap will be filled with 
a window, cased opening, inswing left-hand door, inswing right-hand door, 
outswing left-hand-door, or outswing right-hand door as specified by the pop-up 
menu at the bottom of the screen.  After adding the door or window, and before 
starting the next wall segment, changing the popup gap menu setting will change the 
current window or door.  The attributes of the window or door are modified by the 
settings in the "Settings > Windows and Doors" menu.  The door/window style can 
be modified immediately after it is drawn by changing the values in “Settings > 
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Windows and Doors” and tapping the “Replace” button (tapping the "Done" button 
applies the changes to future doors/windows and leaves the current one unchanged). 

When drawing walls with gaps, reference icons appear that show the measurement 
being entered.  The default measurement distance is the overall length of a wall, as 
depicted in Figure 8. 

 

Figure 8 - Walls&Gaps tool with reference icons 

Entering overall wall lengths create more accurate floor plans than accumulating 
shorter measurements because it eliminates accumulation error that can result when 
adding several shorter lengths.  However, there are times that such accuracy is not 
necessary and it is easier to measure shorter lengths.  Tapping the Measure mode 
button changes the type of measurement being entered.  For example, tapping the 
button for the drawing displayed in Figure 8 changes the location of the reference 
icons (see Figure 9). 

 

Figure 9 – Reference icons repositioned 

Irregular floor plans, such as the one depicted in Figure 10, can be easily drawn with 
the Walls&Gaps tool.  After tapping an approximate wall angle, an exact wall angle 
is entered by tapping on the “a” field (see Figure 11).  
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Figure 10 - Floor plans with few orthogonal corners can be drawn quickly with the 
Walls&Gaps tool 

 

Figure 11 - An irregular corner drawn with the Walls&Gaps tool: Relative or Polar 
angles can be entered for corners by tapping on the “a” field 

 Angles can be measured in the field with a protractor or calculated with the 
“Triangulate”  calculator at the top of the angle popup keypad (see Figure 12).  
When drawing walls and lines, measurements are stored in two sides of the triangle.  
When three valid triangle sides are entered, the angle opposite the hypotenuse is 
calculated and set in the field at the bottom of the keypad.  The value is applied 
when the “Enter” button is tapped (tap “Esc” to cancel without applying the angle).  
When the angle is explicitly entered with the keypad, the hypotenuse is updated and 
can be used to verify field conditions. Entering non-orthogonal lines is generally 
simpler when the “Relative Angles” setting is on, which is located in the “Settings > 
Walls and Gaps” dialog. (Relative Angles are the local angle between adjacent line 
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or wall segments as opposed the angles of the coordinate system.) 

 

Figure 12 - The angle keypad and optional “Triangulate” calculator simplifies the 
drawing of angled walls. 

 
 

 
 

 

Arc, Box, Circle:  These tools have two or three drawing types for each.  For 
example, an Arc can be defined by its center point and two points on the radius, or 
by tapping three points on the radius. After selecting the tool, these options are 
available to the right of the toolbar (see Figure 13).  After selecting the desired 
option, follow the command line to complete the operation. 

 

Figure 13 - The Circle tool displays three modes 

 
Text: Adds text to any location in the drawing.  After activating the text tool, tap the 
location and enter the text into the popup text keypad.  The size of the text is 
specified by “Settings > Preferences > Text Size” (see Preferences in “Settings 
Menu,” page 32).  Text in the drawing can be edited by selecting it with the Pick 
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tool as described in “Select Tools,” page 28. 

   Punchlist:  ‘Punchlist’ is the term used by building professions during 
construction to describe a list of outstanding items in a project to be completed.  
This tool adds punchlist items to the drawing and displays their locations in the 
drawing or as a list.  ZiPCAD contains in internal database in each drawing for 
tracking punchlist items.  The punchlist can be exported as a comma-separated 
values (CSV) spreadsheet to the expansion card or to a PC during a Hotsync.  The 
punchlist items can also be included in an exported DXF drawing (see “Chapter 5. 
Importing and Exporting,” page 35).  Each punchlist spreadsheet item is assigned a 
unique key for cross-referencing the exported DXF drawing (see Figure 14).  The 
user can then combine the exported punchlist spreadsheet and drawing into a single 
punchlist report. 

 

Figure 14 – Punchlist spreadsheet and drawing with cross-reference IDs exported 
from ZiPCAD 

Creating a Punchlist with ZiPCAD 

While users may develop their own standards and preferences for creating and 
formatting punchlists, the typical steps taken are: 

1. If referencing existing drawings created from a desktop CAD program, such as 
AutoCAD , turn on the layers in the drawing that you wish to include in the 
final punchlist report image.  This drawing usually consists of plans with 
minimal text, such as the labels of the rooms and a title block for each floor 
(see Figure 14). 

2. Export the layers to a DXF file and import the file into ZiPCAD.  If several 
users will be supporting updating the punchlists for the same project on 
different devices, it’s generally a good idea for each user’s drawing to have a 
unique name; for example, the name of the project followed by the user’s 
initials (“MainStreet-MJ”).  Naming with this convention allows for beaming 
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project drawings among users without fear of overwriting or confusing 
drawings.  This approach is particularly handy when multiple users are 
supporting the same punchlist on different devices. 

3. Open the imported drawing in ZiPCAD  and set up a saved view for each layer 
group for quick reference.  For example, turn on all of the First Floor layers, 
activate the Saved Views tool (see page 29), and create a view named “1-Flr.”  
Doing likewise for all the layer groups will allow you to quickly change visible 
layers in the field. 

4. After creating a punchlist in the field, the user can export the punchlist as a 
spreadsheet and export the drawing as a DXF file for cross-referencing with 
the punchlist (see “Chapter 5. Importing and Exporting” on page 35).  If 
multiple users have modified the punchlists, they can be merged into a single 
drawings punchlist before being exported. 

Punchlist Items in a Drawing 

After activating the Punchlist tool, all visible punchlist items are displayed as an 
icon accompanied by a brief description (see Figure 15). 

 

Figure 15 – Punchlist items displayed as icons with brief descriptions 

New punchlist items are created by simply tapping the location for the item in the 
drawing.  A punchlist dialog is then displayed with several input fields (see Figure 
16).  All fields are optional.  While the specific use of fields may vary depending on 
the user, typical uses are described in “Editing Punchlist Items” on page 26. To edit 
an existing punchlist item, simply tap the item’s icon in the drawing. 
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Figure 16 – Punchlist item editor 

Punchlist Items in a List 

In addition to viewing punchlist items in drawing, punchlist items can be displayed 
in list format by tapping the “List” button at the bottom of ZiPCAD’s interface when 
the Punchlist tool is activated (see Figure 15).  The list shows all punchlist items in 
the drawing, regardless of whether or not they are on a visible layer (see Figure 17).  
Completed items are displayed with their checkbox checked (unless the setting “List 
completed items,” described below, is not active).  The order of the values displayed 
in the list from left to right is specified by the punchlist settings (see “Punchlist 
Settings” page 26).  Values of a punchlist item that are blank or unassigned are 
depicted with an underscore (“_”) in the list.  The list can be scrolled left and right 
with the arrow buttons at the bottom of the dialog.  Specifying a value for “Sort” at 
the top of the List dialog sorts the contents of the list appropriately. 

 

Figure 17 – List of punchlist items 

The checkbox associated with each item is checked if the punchlist item has a 
Completed date associated with it.  You can specify whether or not you want 
completed items displayed by setting the proper value in the Punchlist Settings 
dialog. To view or edit the details of a punchlist item, simply tap the item in the list.  
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Punchlist Settings 

The punchlist setting associated with the punchlist have an effect on the display of 
punchlist items in exported DXF drawings, their format on the device, and their 
format in exported CSV files.  To access the punchlist settings, activate the 
Punchlist tool, tap the “List” button at the bottom of the screen, and tap the 
“Settings…” button at the bottom of the list displayed (see Figure 17).  The Settings 
dialog shows the columns to be displayed when listing the punchlist items on the 
device or in the exported CSV filed.  The user can show as many or few columns as 
desired. 

When “List completed items” is checked, punchlist items with a completion date are 
displayed in the drawing (both on the device and exported DXF drawings) and in 
lists (on the device and exported CSV files).  When unchecked, the completed items 
are hidden from view, though still retained in the database. 

The “Font size” specifies the font size used when displaying punchlist items in the 
drawing on device and the exported DXF file.  The “ID prefix” is an optional field to 
proceed punchlist item IDs in exported DXF drawings. 

Editing Punchlist Items 

Punchlist items are displayed in the drawing when the Punchlist tool is active and 
hidden otherwise.  When creating a new punchlist item or editing an existing one, 
the more commonly entered punchlist items are preset in customizable popup 
menus.  For example, the Category section has many preset value associated with it 
in its adjacent menu.  You can customize the list of items by adding new items and 
deleting or renaming existing items by scrolling down the menu and tapping the 
“Edit categories” entry.  The default contents of the menus can be imported from 
other ZiPCAD drawing’s punchlists by using the “File > Import” feature (see 
“Importing punchlists from ZiPCAD drawings,” page 37). 

The punchlist menus are initially populated with the defaults in the 
ZiPCAD~DefaultPunchlist.PDB file.  This file is a standard ZiPCAD drawing and is 
only unique in that its name is reserved for the default punchlist.  If you create 
custom punchlist menus that you would like to use as the default, simply give it this 
name.  If you use more than one type of punchlists for various projects types and do 
not want to use any particular punchlist as a default, you can have no ZiPCAD 
drawing with the default punchlist name and, instead, import punchlists explicitly by 
using the “File > Import” option (see “Importing punchlists from ZiPCAD 
drawings,” page 37). 

Below is a list of values associated with each punchlist item.  These values are 
organized as columns in the exported CSV file and listed in the ZiPCAD punchlist. 

Location is the reference name in the drawing where the punchlist item is located; 
typically a room name or location name. You can add new locations by tapping 
“Edit locations…” at the bottom of the popup list or you can browse the drawing to 
select a location name by tapping the “Pick in drawing…” option.  After tapping 
“Pick in drawing…” the dialog closes and you can pan and zoom the drawing to tap 
the name associated with the location.  After selecting and you are returned to the 
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dialog with the location name inserted into the list. 

Category is the general category description of the punchlist item. 

Entry is a subcategory of Category.  Changing the Category menu value changes the 
list of available values in the Entry menu.   

Description is optional text to explain the nature of the punchlist item in more detail 
than afforded with the Category and Entry menus.   

Attn is an abbreviation for “Attention” and supports a list of contacts that should be 
notified of the punchlist item. 

Author is the name or initials of the individual entering the punchlist item.  Several 
people can support the punchlist on different devices and the resulting punchlists can 
be merged into a single punchlist (see “Importing punchlists from ZiPCAD 
drawings,” page 37). 

Completed checkbox is checked if the punchlist item is assigned a Completed date.  
Completed punchlist items are retained but can be optionally hidden from view (see 
“Punchlist Settings” on page 26).  Checking the box sets the completion date to 
today’s date.  Unchecking the box clears the completion date.  Completed punchlist 
items are hidden from view of the “List completed items” setting is off. 

Find in drawing button closes the dialog and changes the visible layers and location 
in the drawing to display the location of the punchlist item.  The button is hidden 
when the punchlist item in within view in the current drawing. 

Delete… followed by a confirmation permanently deletes the punchlist item.  No 
copy of the item is retained in the punchlist after it is deleted.  If you simply want to 
stop displaying the item but do not want to delete it, you may consider tapping the 
Completed checkbox. 

Cancel closes the dialog without saving any changes.  

Done saves changes and closes the dialog. 

More… displays the addition fields listed below. 

Logged is the date the punchlist item was entered.  This date is automatically set 
when a punchlist item is created but can be modified by tapping the value and 
specifying a new date. 

Completed is the date the punchlist item was completed.  This date is set to today’s 
date when the Complete checkbox is set and can be modified by tapping its value. 

Due is the optional due date of the item.   

Remark is for comments associated with the punchlist item that are not appropriate 
for the Description field.   

Reference is for documents generally not in the drawing or punchlist, such as a 
project specification, which are related to the punchlist item. 
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Type is an optional field to further define the type of punchlist entry.  Firms often 
have internal classifications for punchlists that can be specified here. 

Relocate in drawing  button closes the drawing and allows the user to browse and tap 
a new location for the punchlist item.  (This button is hidden when new punchlist 
items are being created.) 

ID  is the unique identification number assigned the punchlist item.  These numbers 
are maintained internally in ZiPCAD  and may not be defined by the user.  When the 
punchlist is exported to a DXF drawing, the punchlist item IDs are used as labels for 
the items.  The ID is also included in the exported CSV list so that the list and the 
drawing can be cross-referenced. 

Less… returns the user to the previous dialog. 

 
Sketch: This tool allows the user to quickly draw freehand by dragging the stylus on 
the screen to draw.  Because this tool requires the stylus to be dragged, it is not 
possible to use Anytime Windowing while the Sketch tool is active.  To zoom and 
window, tap the “Window” button displayed at the bottom of the screen when this 
tool is active. 

 
Dimension: Horizontal, vertical, and aligned dimensions can be added to the 
drawing.  After selecting the dimension tool, a popup menu allows the user to 
specify the type of dimension.  After selecting the type, follow the command line to 
add the dimension to the drawing.  Three taps are required: two for the start- and 
end-points and one for the location of the dimension line. 

 
Arrows: Arrows can have open or closed triangle heads or ticks.  They can also be 
straight-lined or curved.  After starting the arrow tool, the user can select from these 
options in the input area at the bottom right of the screen.  To draw the arrow, 
simply tap the arrow points in the drawing area.  Additional arrow settings, such as 
the color and aspect ratio of the arrow head, can be specified by tapping the menu 
button and selecting “Settings > Arrows.” 

 

Select Tools  

Many ZiPCAD  tools operate only on selected objects.  For example, “Edit > Delete” will 
delete selected entities and groups in the drawing.  Selected objects are indicated as being 
drawn more thickly than unselected objects.  Below are the Select tools available from the 
toolbar. 

 
Pick: Tap entities and groups to select them.  Tapping selected objects deselects 
them.  When picking entities, the “Match” and "Edit" buttons appear at the bottom 
of the screen.  Tap the “Match” button to set the current line drawing properties and 
active layer to match the tapped entity (see “The “Match” Button,” page 17).  Tap 
the “Edit” button to change the coordinate properties of the entity (see “The “Edit” 
Button ,” page 17). 
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Select All / Deselect All: Selects/deselects all of the visible objects in the drawing, 
including objects outside of the screen’s viewing area.  Objects on hidden layers are 
not selected. 

 
Area Select:  Selects objects completely contained in a user-specified rectangular 
window. 

 
Area Include: Select objects completely and partially contained in a user-specified 
rectangular window. 

 View Tools 

There are several ways to navigate in the drawing.  The two most commonly used view 
tools, the Anytime Window tool and the Pan-and-zoom device-key tools are accessible at 
anytime without using the toolbar tools (see “Anytime Windowing,” page 15).  Below are 
the View tools available from the popup toolbar. 

 
 

Extents: This will bring all the objects on visible layers within view. 

 

Full Screen:  Hides the toolbar area.  Users may zoom and pan in this view with the 
device keys or Anytime Windowing .  Tap anywhere in the drawing to exit full-screen 
viewing. 

 

Window:  Allows the user to zoom into a rectangular area by tapping (not dragging) 
two diagonal corners of the desired rectangular viewing window.  

 
 

Prev Window / Next Window:  Scrolls through the ten most recent windows 
specified by the Window tool or Anytime Windowing (see “Anytime Windowing and 
Device-key Viewing,” page 15). 

 

Refresh: Like most CAD programs, for performance reasons ZiPCAD does not 
redraw the screen after every operation.  Some operations, such as deleting objects 
that overlap other objects, can muddle the screen.  This tool redraws the current 
view. 

 

Recenter:  Allows the user to pan through the drawing by tapping a new center for 
the viewing area. 

 
 

Zoom In / Zoom Out:  Zooms in/out of the drawing’s current view. 

 

Saved Views:  Allows users to name and save the current view so that the exact view 
can be revisited at later.  To save the current view, start this tool, tap New at the 
bottom of the dialog window, write a name for the view, and tap “Done.”  To recall 
a previously saved view current, tap the name of the desired view and “Done." 

Build Tools 

Tools common to most CAD programs, such as trimming, moving, mirroring, etc., are 
collectively referred to as Build  tools in ZiPCAD . 
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Corner:  Extends/Trims two user selected lines to form a corner of any angle.  After 
starting the tool, tapping two lines extends or trims the lines to form a trimmed 
intersection. 

 
Offset:  Copies an entity, such as a line or circle, a specified offset distance.  If the 
“Lock” button is activated, the distance is fixed by the value in the “d” input field.  
When not locked the distance is specified by the tap of the stylus.  The user can 
toggle the “Lock” activation on or off at any time by tapping its button and can 
modify the offset distance by tapping the “d” input field and entering a new value in 
the pop-up keypad. 

 
Line Trim :  Trims/Extends selected entities, such as lines or arcs, to the line 
specified as the trim line.  Note: after selecting a trim line, users will be prompted to 
“Tap side to remove”. 

 
2-Pt Trim :  Performs the same operation as Line Trim except the user defines a trim 
line by tapping two points instead of selecting a line. 

 
Break: Breaks an entity at the tapped point.  If two or more lines are tapped at the 
same time (e.g., a line intersection) then a selected line is given precedence. 

 
Seg. Trim: Deletes a segment from an entity.  The first tap selects the entity and the 
second and third tap defines the trim points.  When trimming circles or ellipses, the 
first tap selects the entity and determines the portion of the curve you want deleted. 

 
Mirror:  Reflects selected entities about a line specified by two points.  To create a 
copy of the mirrored image in the original location, check the “and Copy” box 
displayed at the bottom of the screen immediately after the Mirror tool is activated. 

 
Stretch: ‘Stretches’ objects by moving their points within a user-defined rectangular 
area a specified distance. 

 
Move:  Moves the selected objects a given distance.  To create a copy of the moved 
object in the original location, check the “and Copy” box after activating the Move 
tool. 

 
Rotate:  Rotates the selected objects a given angle.  To create a copy of the rotated 
object in the original location, check the “and Copy” box after activating the Rotate 
tool. 

 
Resize:  Enlarges or shrinks selected objects a specified amount.   

 
 

Group/Ungroup:  Group collects selected entities into a single group on the current 
layer.  Ungroup disassembles a group. 

 
Query:  Gives information about the selected objects.  If more than one object is 
selected when the tool is activated, it gives all of the information common to the 
selected objects.  For more detailed information, select one object at a time.  After 
activation, it gives information on subsequently tapped objects.   

 
Measure:  Displays the distance or angle between user-specified points.  Three types 
of modes are offered when the tool is activated: Cartesian (x,y), Polar (d,a), and the 
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angle between two lines formed by three points. 

 
Area: Calculates the area of a user-specified polygon.  If any lines of the polygon 
overlap, the area is invalid and a 0.0 is displayed. 

 
Door: Draws a door after the user specifies the hinge point, strike point, and a third 
jamb corner point and trims the opening in the wall.  The hinge, strike, and wall 
points must fall on an entity (usually a line or wall).  The door style can be modified 
immediately after it is drawn by changing the values in “Settings > Windows and 
Doors” and tapping “Replace.” 

 
Window:  Similar to the Door tool except draws a window (see instructions for the 
Door tool. 

 
Symbols:  DXF drawings often contain blocks (referred to as “symbols” in 
ZiPCAD).  Symbols in one drawing may be copied into another by starting the 
symbols tool, tapping the "Symbols..." button, and selecting the drawing with the 
desired symbols. After the tool is activated, a table of a table of available symbols is 
shown.  Tapping one of the symbols and then tapping the location of the symbol 
will copy it into the current drawing.  Tap the "Edit" button that appears at the 
bottom of the screen to modify the symbols attributes, such as the rotation angle and 
scale.   

Symbol Libraries 

Users can create a symbol libraries by loading commonly used blocks into one or 
more DXF drawings and importing them into ZiPCAD.  For example, commonly 
used plumbing fixtures can be placed a drawing in a desktop CAD program, such as 
AutoCAD , and exported to a drawing called “Plumbing.dxf.”  The drawing can then 
be imported into ZiPCAD.  When a plumbing fixture is needed in the current 
drawing, simply activate the Symbols tool, browse to the “Plumbing” drawing, and 
select the desired symbol. 

 
Weld: Selecting two line segments and then activating the Weld tool combines the 
two lines into a single line defined by the outer-most endpoints of the two lines. 

 

Menus & Settings 
Three pull-down menus are provided: Drawings, Edit, and Settings.  These menus are 
hidden when not being accessed to maximize the drawing space and are accessible by 
tapping the menu button (see Figure 5). 

File Menu 

The File menu is identical to the File menu found in most desktop software applications.   

● New:  Start a new drawing.  If the drawing currently being edited is named, it is 
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automatically saved.  If it is not named, the user is given the option of saving or 
discarding the drawing. 

●  Open…, Save As…:  Displays a File Dialog box listing all of the ZiPCAD drawings on 
the RAM and expansion card.  These dialogs also give the user the option of deleting 
existing drawings. 

● Info: Displays information about the drawing, such as the size of the drawing and the 
number of entities. 

● Import:  Imports a punchlist or DXF drawing.  See Chapter 5, Importing/Exporting 
DXF Files, for more information. 

● Export:  Exports a CSV punchlist or DXF drawing. See “Chapter 5, 
Importing/Exporting DXF Files” on page 35 for more information. 

 
Beam: Transmits the current ZiPCAD  drawing to another device. 

Edit Menu 

The Edit menu also will be familiar to most users.  It has common editing features, such 
as Cut/Copy/Paste, Undo/Redo, and Delete, found is most applications.  Because these 
features are often accessed, Command Bar shortcuts are provided for each (see page 13, 
“Command Bar Shortcuts,” for more information).  The icons shown represent the 
Command Bar shortcut icons. 

 

 Undo/Redo:  Any change to the drawing can be infinitely undone or redone with 
these tools.  Note that exiting the drawing clears the Undo/Redo memory.  

 
 

 
 

 

Cut/Copy/Paste:  These are clipboard features for moving or copying objects 
across layers and drawings – e.g., To move an object to another layer; select the 
object(s) using any of the selection tools, choose Cut from the Edit Menu, select 
“Settings > Layers,” set the desired Layer as active, tap “Done” to return to the 
drawing, and choose Paste from the Edit Menu. 

 

Duplicate:  Creates a copy of the selected entities in the same location.  If the 
move or rotate tools are active, the duplication is offset or rotated by the amount 
specified.  For example, to copy a series of entities an identical distance, use the 
Move tool (with “and Copy” set) follow by several Duplicate commands.  A copy 
of the entity will be inserted by the amount specified in the Move tool. 

 

Delete:  Similar to Cut, except a copy of the objects is not placed on the 
clipboard. 

Settings Menu  

 The Settings menu has features specific to CAD. This menu allows users to 
customize their drawings and ZiPCAD preferences. 
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● Layers:  Layers can be added, deleted, renamed, toggled on/off, and set as the active 
layer.  The active layer receives all newly created entities.  To move objects to another 
layer use the Cut/Copy/Paste tools as described in the “Edit Menu” on page 32. 

● Line Types/Colors:  Four line types are available:  solid, dotted, dashed, and dot-
dashed.  Selecting a line type will change the type for all of the selected entities and  
for all newly created entities.  For devices that support color, 16 user-customized 
colors are provided.   Tapping the "DXF Number" button displays the number assigned 
to the color when importing and exporting DXF files.  This allows you to customize 
your ZiPCAD  color table to match the settings of your desktop CAD program. The 
active lines settings are displayed in ZiPCAD’s interface (Figure 1). 

● General Preferences:  Basic user preferences, including Metric/Imperial units of 
measure, keypad default units, unit display format, text size, Polar/Cartesian coordinate 
systems, Relative/World origin points, angle units, zooming and saving preferences are 
specified here (see Figure 4).  The text size is the size of the font in drawing space 
when the image is exported as DXF. 

● Snapping:  The snap settings available are Endpoint, Midpoint, Perpendicular, 
Intersection, Curve Quadrant, and Snap Angle.  The maximum distance between the 
tap location and the snap point is specified by the Tap Window setting.  If you find 
you’re having trouble specifying snaps, enlarge this setting.  Likewise, if you find 
you’re snapping too often, reduce this setting.  If you feel your taps are not being 
accurately interpreted, you may need to run the digi tizer feature of your device (see 
your devices manual for more information). 

● Help: Displays some tips for getting started with ZiPCAD.  When running certain 
ZiPCAD  tools a small information button with an “i” in it appears in the lower right-
hand corner of the screen (see Figure 1).  Tap this button for information on the 
currently active tools.  

● About ZiPCAD :  Displays some company information and the “Register…” button (for 
unlicensed copies) which allow unregistered users to enter their unique ZiPCAD key. 

● Windows and Doors:  Several settings for the rendering style of windows and doors 
can be customized, including door, window, door swing, and glass color (if color is 
supported on the device), jamb widths, threshold widths, etc.   (If the check boxes next 
to the color selection is not checked, the color dictated by the values in “Settings > 
Line Type/Color” are used.)  Tap “Done” to apply the new settings to subsequently 
created windows and doors.  If a window or door was created immediately before 
opening the Windows and Doors dialog, the button “Replace” appears at the bottom of 
the screen.  Tap this button to apply the settings to the newly created window or door. 

● Custom Shortcuts:  Each tool of the toolbar is assigned a custom single-character 
shortcut key (see Figure 2).  Edit the text next to the tools icon to specify the shortcut 
for the tool.  The special characters Carriage Return, Space, and Backspace are given 
the two-character descriptors “CR,” “SP,” and “BS,” respectively. 

● Distance Meter: Palm OS devices with Bluetooth capabilities can remotely connect 
with a Leica Disto distance meters.  This menu contains buttons to simply connect and 
disconnect from the distance meter.  The round off setting rounds off measurements to 
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the specified amount, so for a round off of 1/4”, an entry of 2-7 15/16” will be entered 
as 2’-8”.  See “Chapter 6. Linking to a Distance Meter,” page 39, for more information 
on linking ZiPCAD to a distance meter via Bluetooth. 

● Arrows: Specifies the size and aspect ratio of the arrow head the Arrow tool. 
Optionally, the user can specify the color of the arrow head and shaft by checking the 
corresponding checkbox. 

● Walls and Gaps: Specifies how walls are drawn by the Walls&Gaps tool (page 19).  
When walls intersect other walls or lines, ZiPCAD  can try to trim the lines to create a 
clean intersection.  Similarly, walls can be capped when no intersection occurs. 
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55..  IImmppoorrttiinngg  aanndd  
EExxppoorrttiinngg  

 

The Windows installation is bundled with a conduit program that resides on the PC for 
importing and exporting drawing DXF files and punchlist CSV files.  Other systems 
installations, such as the Mac OS or Linux, or that do not Hotsync with any device, such 
as those networked with GoodLink™, do not have a conduit, but can import and export 
DXF and CSV files to and from the device’s expansion card. 

For ZiPCAD installations that Hotsync to a PC, a drop folder is created on the PC's 
desktop named "ZiPCAD Files."  To import or export files to the device’s expansion card, 
use ZiPCAD’s “File > Import” and “File > Export” features. 

DXF Drawings 
ZiPCAD  reads and writes DXF files that adhere to the R12 DXF specification.  DXF files 
can be read or written by most CAD programs and some drawing programs.   

The line colors associated with DXF drawings can be optionally customized to match 
your desktop CAD application’s in ZiPCAD by selecting “Settings > Line Types/Colors” 
and tapping “Edit Palette” and “DXF Numbers.”  Selecting the proper numbers will 
insure that the ZiPCAD  colors match your desktop CAD program’s. 

Punchlist items are included in DXF drawings when the CSV punchlist file is 
simultaneously exported.  Exporting only the DXF file excludes the punchlist items. 

Importing DXF files from Windows 

ZiPCAD  running on devices that Hotsync to a Windows PC can import DXF drawings 
either through ZiPCAD’s conduit residing on the PC or through the device’s expansion 
card.  The steps for importing drawings via the Windows conduit are listed below. 

1. From ZiPCAD , tap “File > Import"  

2. Tap "Computer" and the units of the DXF file being imported. 

3. If ZiPCAD has not yet created the folder "ZiPCAD Files," (or if the user deleted the 
folder) a message will appear saying the folder will be created the next time you 
HotSync.   

4. A folder is created on your PC’s desktop titled "ZiPCAD Files" that contains a 
subfolder called "DXF Files to Import."  Drag and drop one or more DXF files for 
importing into this folder and perform a HotSync operation.  The files will be imported 
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into RAM during the operation.  After the Hotsync operation the DXF files are moved 
to the “Completed Imports” folder. 

Note that once the folder is created on the desktop, you needn’t tap “File > Import” before 
importing.  Simply drop the files into the “DXF Files to Import” folder and Hotsync. 

Importing DXF files from the Expansion Card 

ZiPCAD can import and export DXF files to the device’s expansion card where they can 
be uploaded or downloaded to the desktop computer via a card reader, the Palm Desktop  
software bundled with the device, or similar third-party programs.  

1. From ZiPCAD , tap “File > Import DXF"  

2. Tap "Card," the Units of the DXF file, and “Done.”  

3. A file dialog is shown.  Browse to the DXF file and tap "Import."  A new drawing will 
be created and populated with the contents of the DXF file.  

Exporting DXF files to Windows 

Drawings on the device can be exported to a Windows PC during a Hotsync operation by 
following the steps below. 

1. From ZiPCAD , tap “File > Export DXF" and tap the “DXF Drawing” button to queue 
the current drawing for exporting.  To include punchlist items in the exported drawing 
also select the “CSV Punchlist” button (leaving this button unselected excludes 
punchlist items from the drawing).  Note that the punchlist settings, such as Font Size, 
List completed items, and column sorting are applied to the drawing (see “Punchlist 
Settings,” page 26). 

2. Tap "Computer" and the units of the DXF file.  

3. If not already existing, ZiPCAD creates folder on your PC's desktop named "ZiPCAD 
Files" which contains subfolder name "Completed Exports." Exported DXF and CSV 
files are placed in the folder during the Hotsync operation. 

Exporting DXF files to the Expansion Card 

Drawings can be exported directly to the expansion card where they can be loaded into a 
PC, Mac, or other operating system via a card reader, software bundled with the device or 
third party software. 

1. From ZiPCAD , tap “File > Export"  

2. Tap “DXF Drawing,” "Card," and the units of the DXF file.  

3. A file dialog is shown.  Name the DXF file and tap "Export."  
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CSV Punchlist Files 
Punchlists can be exported as a spreadsheet in the comma-separated value (CSV) file 
format, which is a standard format supported by most spreadsheet and database 
applications, such as Excel, Access, and WordPerfect. 

To specify the punchlist values to export, activate the Punchlist tool, tap the “List” button 
at the bottom of the screen, and tap the “Settings” button at the bottom of the List dialog.  
The order of the columns is specified by the number column fields.  The option for 
whether or not to include completed punchlist items is determined by the “List completed 
items” setting.  The sorting order of the rows is specified by the Sort field at the top of the 
List dialog (see Figure 17). 

Exporting punchlist CSV files to Windows 

The punchlist can be exported directly to a Windows PC during a Hotsync operation as a 
CSV file.   

1. From ZiPCAD, tap “File > Export” and select “CSV Punchlist.” 

1. Tap “Computer.”   

2. Perform a Hotsync.  The CSV file will be exported to the “Completed Exports” folder 
in the “ZiPCAD Files” on your PC’s desktop. 

Exporting punchlist CSV files to the expansion card 

The punchlist can be exported as a CSV file directly to the expansion card. 

1. Specify the punchlist format as described above. 

2. From ZiPCAD , tap “File > Export” and select “CSV Punchlist.” 

3. Tap “Card.” 

4. Tap “Done.” A file browser will display that allows you to specify the location and 
name of the file on the expansion card. 

Importing punchlist CSV files 

ZiPCAD  punchlists contain important information relative to punchlist items that are not 
supported by the CSV file format, such as visible layers and punchlist item locations in 
the drawing.  Consequently, CSV punchlist items cannot be imported into ZiPCAD.  
However, punchlists in other ZiPCAD drawings can be imported into the current drawing 
by following the directions below. 

Importing punchlists from ZiPCAD drawings 

Punchlists are stored within each ZiPCAD drawing and can be merged with the punchlists 
of other ZiPCAD drawings.  This capability allows several users to enter or modify 
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punchlist items on separate devices and then merge the resulting punchlists into a single 
punchlist. 

In addition to merging punchlists, there are times that you may want to only import the 
default popup menu values of punchlist, such as categories, entries, and authors, and not 
the individual punchlist items themselves.  This option is provided during the import steps 
listed below. 

1. Tap the ZiPCAD  “File > Import” menu option. 

2. Select “PDB Punchlist.” 

3. To import only the default menus of the imported punchlist, such as categories, entries, 
and authors, select the checkbox displayed.  If this checkbox is left unchecked, then 
both the default menus and the individual punchlist item are imported. 

4. Tap “Done” and browse to select the drawing containing the punchlist to import.  
Please note that the two drawings must have different file names, regardless of whether 
or not one file resides in RAM and the other resides on the expansion card.  If both 
files have the same name, rename one of them before importing. 
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66..  LLiinnkkiinngg  ttoo  aa  DDiissttaannccee  
MMeetteerr  

 

 

Figure 18 - Leica Disto Plus Distance Meter 

A distance meter is not necessary when using ZiPCAD; however it can greatly increase 
the speed of creating and editing floor plans and site surveys. 
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Drawing Existing Conditions with a Distance Meter 

  Measuring existing conditions without a distance meter is often done with two 
people – one person operates the tape measure and calls off dimensions, while the 
ZiPCAD operator draws the plan and enters the dimensions.  Measurements taken with 
the distance meter are automatically uploaded to ZiPCAD , allowing a single operator to 
both draw the plans with ZiPCAD and take the field measurements in less time than it 
takes for two people operating without the distance meter, dramatically reducing the 
required manpower to create existing conditions. 

Leica Disto A6 

Leica Geosystems’ most recent Bluetooth distance meter, the Disto A6, replaced the Disto 
Plus.  Both are similar in functionality and capabilities.  The are some differences, 
however; the most significant are the Enter functionality moved to the Bluetooth  key; the 
Delete key has been removed; and –/+ keys have replaced the Tracking and Pythagorean  
keys.  These changes slightly alter the interface between the user, the distance meter, and 
ZiPCAD, as described below. 

Operating the Leica Disto 

The distance meter comes with a complete operator’s manual that discusses its many 
features, including features not described here.  Please familiarize yourself with the 
distance meter before attempting to use it with ZiPCAD.  This section describes just the 
basics for connecting and using the device with ZiPCAD . 

Connecting to ZiPCAD 

Connecting the distance meter to ZiPCAD should only be done from within the ZiPCAD 
program – do not connect to the distance meter using the Palm Bluetooth program before 
attempting to connect with ZiPCAD. Begin by putting the distance meter in search mode 
by turning the device on and pressing the “Bluetooth” button (see Figure 18).  The 
Bluetooth On icon will begin flashing, indicating the device is searching for a Bluetooth 
connection.  This icon must be flashing (not solid or off) to connect to ZiPCAD.  From 
ZiPCAD, tap “Settings > Distance Meter.”  To connect to the laser for the first time, tap 
the “Bluetooth Connect” button.  Select “Nearby devices” from the menu.  A list of 
Bluetooth devices in the area is displayed.  Select the distance meter and tape “Done.”  
Subsequent connections can be made by tapping “Reconnect to Previous” button. 

When a connection between the two devices is established, the distance meter will beep 
and the Bluetooth icon will stop flashing and remain solid.  Should the connection be 
dropped, such as when ZiPCAD  is exited, the distance meter beeps and the icon begins 
flashing.  When ZiPCAD  is restarted, it automatically reestablishes the connection. 

Dropped Connections 

When the Bluetooth connection is dropped between the devices, such as when the 
distance meter powers itself off due to inactivity, the Palm device will often pause for 5-
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10 seconds as it recovers.  The device has not crashed.  Simply wait until it recovers and 
follow the instructions above for reconnecting. 

Disto Plus’ Buttons 

Please refer to the Leica Disto Plus’ manual for a full description of its many features.  
Below is a description its most commonly used buttons when using ZiPCAD.  

 2nd Button: Many buttons have an alternate function listed in blue above or adjacent to 
the button.  When the 2nd feature is active, these functions are accessed.  This is 
generally the preferred setting when using the distance meter with ZiPCAD .  

 Power: Toggles the device on and off.  Note that the 2nd feature must be off to turn the 
device off. 

 Enter: Uploads current distance reading into active ZiPCAD tool.  This functionality is 
assigned to the Bluetooth button of the Disto A6, when the device is in 2nd mode. 

 Arrows: Uploads the angle of the arrow direction to ZiPCAD  and the current 
measurement (if valid).  Because the measurement is also uploaded, pressing the Enter 
key is often not necessary.  For most tools, the angle matches the orientation of the 
ZiPCAD drawing, so pressing the “up” arrow enters and angle in the drawing pointing 
upward.  However, when using the Walls&Gaps and Line tools, if the “Settings > 
Walls and Gaps > Relative Angle” setting is on, the “up” arrow move draws a Wall or 
Gap in the current angle direction, the “left” arrow turns left 90 degrees, the “right” 
arrow turns right 90 degrees, etc.  (Using Relative Angles can expedite drawing plans 
with non-orthogonal angles, such as the one depicted in Figure 10.)  This setting is 
recommend when using the Walls&Gaps tool because it is more intuitive for most 
users and make for faster drawing of floor plans. 

 Delete: Performs and Undo in ZiPCAD – this button is absent on the Disto A6 

 Bluetooth: When not in 2nd mode, this feature toggles the Bluetooth connection on and 
off.  When 2nd mode is active, it sends the current measurement to ZiPCAD . 

 Aim & Distance: Pressing the button once turns the laser on for aiming.  A second 
press takes the distance reading.  Note that this distance in not uploaded to ZiPCAD .  
To upload a distance to ZiPCAD , press the distance meter’s “Enter” button. 

 Reference: The Disto Plus can reference its base, tripod point, or front edge when 
calculating distances.  This button toggles between these three modes.  The current 
reference mode is depicted in the display.  (The Disto A6 does not reference the tripod 
point.) 

 Pythagorean & Bluetooth:  These keys have been remapped by ZiPCAD to scroll 
through the available gap modes when drawing with the Walls&Gaps tool.  For 
example, if the tool inserts a window and you want an inward swinging left-handed 
door, repeatedly press the Pythagorean & Bluetooth keys until the desired door is 
displayed.  For the Disto A6, this functionality has been assigned to the –/+ buttons. 
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Disto Display 

Figure 18 depicts the distance meter modes commonly active when using ZiPCAD for the 
Disto Plus – the Disto A6 display is very similar.  The Single Reading setting indicates 
that pressing the “DIST” button will take a single measurement.  Multiple measurements 
are desirable when recording the largest or smallest measurement of successive readings 
by the distance meter. 

The Bluetooth On indicator is solid when properly connected to ZiPCAD and flashes 
when it looses the connection and is attempting to reestablish connection. 

The “Reference Base” mode is when a distance is calculated as the length from the base 
of the device to the laser point.  This mode can be toggled to the front of the device or the 
tripod point. 

Uploading Readings 

Pressing the Red “DIST”  button once turns the laser on for aiming.  Pressing it a second 
time takes a distance reading but does not upload the measurement to ZiPCAD. Press the 
“Enter” key to upload the dimension to ZiPCAD.  Measurements can be uploaded to any 
ZiPCAD tool that uses dimensions, such as the Walls&Gaps, Offset, Line, Circle, and Text 
tools. 

Uploading Keypad Dimensions 

If a ZiPCAD  keypad is active (see figure 3), pressing the Enter uploads the dimension 
into the keypad – on the Disto A6, press the Bluetooth key while in 2nd mode. 

Uploading Dimensions into Text 

Measurements can be used to annotate a drawing with the Text tool.  For example, to 
record the floor-to-ceiling measurement, simple invoke the Text tool and select a location 
for the text.  The text keypad is then activated.  Pressing “Enter” on the distance meter 
uploads the dimension into the text keypad. 

The “Round Off” Setting 

The Leica Disto Plus is accurate to 1/16th” (1.5 mm).  However, there are many times 
where this accuracy in not required or undesirable.  For example, a 2’-8” doorway may 
measure in the field as 2’-7 15/16”.  Since the nominal 2’-8” measurement is often more 
desirable, the “Round Off” setting can be turned on to round measurements to the closest 
specified increment.  For example, if set to ½”, a 2’-7 15/16” doorway would be rounded 
up to 2’-8”.  (Typically, a desired rounding accuracy is specified before the start of a 
measuring project and then left for the duration of the project.) 
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                          7 
TTrroouubblleesshhoooottiinngg 

 

Whenever possible, ZiPCAD  will detect problems and report them to the user. Such errors 
can occur when running ZiPCAD  on the device or when performing a HotSync operation. 

HotSync Errors 

When an error occurs during a HotSync operation, such as when a file fails to import or 
export, an error message is posted to the HotSync log.  The log is accessible by clicking 
on the HotSync icon in the PC’s tray and selecting “View Log.” 

Error: The DXF file did not import/export after the HotSync operation.  
Cause: Check the HotSync log by opening the Palm Desktop  software and selecting 

“HotSync > HotSync Log…” If the conduit is functioning properly, there will be 
the message “OK ZiPCAD.”  Otherwise, there may be explanations as to why 
ZiPCAD  could not import the file.  If there is not mention of ZiPCAD  anywhere in 
the log, and the HotSync operation was not interrupted, then the software bundled 
with ZiPCAD  did not register with the Palm Desktop software.  This may be 
rectified by reinstalling ZiPCAD . 

ZiPCAD Device Errors 

This section explains errors that may be encountered when running ZiPCAD  on the 
device. 

Error: Folder protected or not empty. 
Cause: The system did not allow the folder to be deleted, likely because it contained some 

files.  Occasionally this message is given when the folder contains no drawings 
and is not protected.  Quitting and restarting ZiPCAD should remedy the issue. 

  
Error: The drawing “MyDrawing" was renamed outside of ZiPCAD.  THIS CAUSES 

CONFLICTS!  It was moved to RAM and given its original name.  (Open 
cancelled) 

Cause: The name of the drawing is stored internally in the drawing’s file and as the name 
of the drawing.  Renaming a drawing within ZiPCAD  updates the name stored 
internally.  However, renaming the drawing using a third-party file browser does 
not and may confuse ZiPCAD . 

  
Error: This drawing was created by an unregistered user is blocked from loading. 
Cause: Registered users may not export drawings as DXF files created by unregistered 

users.  As a result, they are blocked from loading the drawings. 
  
Error: Drawings by this name were found in RAM and on the Card.  This causes 
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conflicts.  Please rename or delete the drawing in RAM.  (Operation Canceled) 
Cause: Drawings on the expansion card are not opened directly from the card.  Rather, 

they are copied first to RAM and then opened.  If a drawing by the same name 
exists in RAM, this presents a problem for ZiPCAD and the operation is 
cancelled.  This problem may be avoided in the future by keeping all of your 
drawing in RAM or on the card.  Note that if a ZiPCAD HotSync operation was 
interrupted, a drawing may have been copied to RAM and not given a chance to 
be deleted during the cleanup.  Simply delete the drawing in RAM if this occurs. 

  
Error: This card is read-only 
Cause: This error occurs if the system reported to ZiPCAD  that drawings could not be 

written to the card. 
  
Error: No card detected 
Cause: An expansion card was not detected.  If one is present, please check that it is 

seated properly 
  
Error: Folders are not supported in RAM 
Cause: The Palm operating system supports folders for expansion cards, but not for 

RAM. 
  
Error: This is a partially installed copy of ZiPCAD for demonstration purposes only. 

Please download a licensed copy from zipcad.com. 
Cause: The installation of ZiPCAD  is not complete, likely because it was beamed to the 

device or similarly installed.  Download and install a new version of ZiPCAD 
from zipcad.com/download.html. 
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